Which directory do I run the composer create-project roots/bedrock your-project-folder-name command?

Let’s say I’ve followed the docs here https://roots.io/trellis/docs/installing-trellis/ and have the directory structure as shown in that first screenshot under example.com

I then move onto the Bedrock instructions and the first step is to run:

composer create-project roots/bedrock your-project-folder-name

but I’m not sure from which directory this command should be run.

If I’ve already cloned bedrock per the instructions on the Trellis docs using:

git clone --depth=1 git@github.com:roots/bedrock.git site && rm -rf site/.git

I’m not sure how or when or where to then run the composer create-project roots/bedrock command to get bedrock installed in the site.

Just follow the Trellis installation instructions from the docs that you linked (or the Trellis README).

You can ignore the Bedrock specific installation info, it’s meant for users that aren’t using Trellis.

Thanks Ben.

At what point is wordpress core pulled into the wp/ directory in the site/web/ ?

I’m following those steps but don’t seem to end up with wordpress itself actually installed anywhere.

You’re using Trellis, right? Continue following the docs:

WordPress core is installed during vagrant up's first provision.

When you do your first vagrant up the scripts will perform a composer install which grabs all the site’s dependencies, including WordPress (as defined in composer.json). You can change directories to site and run composer install yourself, also.

EDIT: jinx.

OK, thanks Ben and MWD.

I’m able to get a Trellis Vagrant box up and running but can’t access the server at example.dev and there’s still no wordpress core in the site structure on my local machine nor in /srv/www/example.com/current on the virtual machine.

I can try running composer install in site/ but would like to understand what I might be missing in the way I am running provisioning my vagrant box.

EDIT: looks like I might have an issue with the installation of ansible. working on fixing that now.

EDIT 2: yep, ansible was borked, looks like I am off and running now.