Roots Discourse

Why is there SSL enabled for "Development"

I have set up the latest version Ansible 2.7.13; Vagrant 2.2.6; Everything goes great (after overcoming some of the hurdles), once the vagrant up command runs successfully, the .dev the version comes with the https even after the wordpress_sites.yml says enabled: false for SSL in the Development directory.

so the default URL should be like this http://example.dev, but it’s being https://example.dev for which all browsers are saying This site can’t be reached

upon further inspection, I tried to curl it and get this message.

dilip@machine:~$ curl -vvv 192.168.50.5
* Rebuilt URL to: 192.168.50.5/
*   Trying 192.168.50.5...
* TCP_NODELAY set
* Connected to 192.168.50.5 (192.168.50.5) port 80 (#0)
> GET / HTTP/1.1
> Host: 192.168.50.5
> User-Agent: curl/7.58.0
> Accept: */*
> 
* Empty reply from server
* Connection #0 to host 192.168.50.5 left intact
curl: (52) Empty reply from server

and another one is

dilip@machine:~$ curl -vvv https://example.dev
* Rebuilt URL to: https://example.dev/
*   Trying 192.168.50.5...
* TCP_NODELAY set
* connect to 192.168.50.5 port 443 failed: Connection refused
* Failed to connect to example.dev port 443: Connection refused
* Closing connection 0
curl: (7) Failed to connect to example.dev port 443: Connection refused

I see it’s the 443 port issue and I enabled it within my local setup but still it’s the same issue.

am I asking the wrong question? is there any solution to this?

I would avoid using .dev these days, see:

1 Like