Woocommerce + Multisite: Dashboard Hanging

Strange one. I’m kinda noting this here as a fix and to see if my fix below is a real fix or just coincidence…

  • Trellis/Bedrock setup
  • Multisite
  • All plugins disabled other than Woocommerce
  • Using the twentyfifteen theme

I can load all pages in the WP Dashboard except for pages in the two WooCommerce menu items. Most of the code in the of the page loads, I can see that in the inspector, but the page just remains blank.

Strangest of all, if I run Gulp on the sage theme I have installed, and log into Wordpress from the localhost domain I can view those pages just fine. So is it an issue with the site’s domain perhaps? When I’m in there the only issue Woocommerce’s system status reports is SoapClient missing.

I’m getting this issue both on development and production servers.

Current fix is commenting out a CSS file in the Woocommerce plugin, but this is obviously not a good long term fix.

Comment out line 44 in class-wc-admin-assets.php

wp_register_style( 'jquery-ui-style', '//code.jquery.com/ui/' . $jquery_version . '/themes/smoothness/jquery-ui.css', array(), $jquery_version );

Removing that CSS makes the pages load fine. How strange!

For prosperity:

Solved this without editing the plugin by deregistering that CSS file in the dashboard. Add this to lib/extras.php

function degregister_woocommerce_style()  {
  wp_deregister_style( 'jquery-ui-style' ); 
add_action('admin_enqueue_scripts', __NAMESPACE__ . '\\degregister_woocommerce_style', 100);

Did you check browser console + server logs to figure out what the error was? Blank page = error.

I didn’t see any errors in the inspector when this issue was happening yesterday … and of course now I can’t recreate the problem today :confused: