Woocommerce subcategories not showing up


I am using Woocommerce on my Sage 10 theme and noticed that the subcategories are not showing up.

Here are things that I’ve tried:

  • Changed Customize > Woocommerce > Product catalogue “Shop page display” to “Show categories” and “Category display” to “Show subcategories”.

  • Added add_theme_support(“woocommerce”) in setup.php in that case subcategories were visible but then my styles, header and footer were not visible.

  • Disabled plugins - no results

I know it’s recommended to use the generoi/sage-woocommerce solution, but showing subcategories shouldn’t be overwhelming for a simple woocommerce site. Is there an easier solution for this?


You should consider that package as a requirement to use Sage 10 with WooCommerce. Why would you not use it? It’s the easiest solution.

Hi, ben

Thank you for the answer! I added generoi/sage-woocommerce solution but it’s only working in my local dev. In staging environment categories still display without any subcategories.

I also check the customize fields and saved permalinks in WP dashboard.

Any ideas what might be wrong?


I’ve tried followings things without any results.

  • Turned off all plugins in staging environment

  • Made sure that my staging env uses same the same configuration as local env (WP and PHP versions).

  • Made sure that subcategories have products

At the moment it seems that the generoi/sage-woocommerce files (woocoommerce/archive-product.blade.php and woocommerce/single-product.blade.php) are not used on the website.

Have you followed all the installation steps for that library?:

And how are you deploying the theme/site? Bedrock + Trellis?

Yes, I have done everything according to the instructions.
I use Local by Flywheel, Bedrock, Sage in local environment.
To deploy I use FTP and I have activated Acorn plugin in my Wordpress.

I’ve used the same deployment method before for other file changes and everything has worked nicely. The woocommerce solution is working nicely on my local environment but not on my staging environment.

As you are using FTP for transferring the files, I deduce that a shared hoster is used? Can you clear the caches, including the PHP Opcache (usually by reloading PHP-FPM) and see whether this helps?

Found solution: I had to run “wp acorn package:discover” command on my shared hosting once again.

Interesting. So you ran that command on development and then uploaded everything to staging? So something must have ended up missing or different on staging, as it didn’t work there until you ran that command directly on there.