Roots Discourse

You need a higher level of permission. - Error?

Really sorry to post this here but I don’t where to turn.
I’ve been working on a multi-site project for a few months now and all of a sudden both locally and on staging I am getting the following error when attempting to edit tags or filters (a custom taxonomy). I can edit categories just fine. These are all on the default WP posts post-type.

The console error when trying to edit terms shows:
Failed to load resource: the server responded with a status of 403 () ........ term.php:1

I’ve disabled all plugins and switched to the default WP theme both locally and on staging and still get the same error attempting to edit tags. Adding tags works just fine!

I have no idea what is going on. Has anyone experience this before?

I am logged in as a super-admin.

Does the current configuration allow the WordPress site(s) to write, are things like plugin auto-updates possible? Bedrock disables this by default (as the site is treated as an app that has release cycles).

The reason is that some plugins (and possibly themes?) rely on quiet improper user roles (notably install_plugins), hence some indeed deny access to admin pages when the site is not allowed to write.

Here’s my config file for development:

<?php
/**
* Configuration overrides for WP_ENV === 'development'
*/

use Roots\WPConfig\Config;

Config::define('SAVEQUERIES', true);
Config::define('WP_DEBUG', true);
Config::define('WP_DEBUG_DISPLAY', true);
Config::define('WP_DISABLE_FATAL_ERROR_HANDLER', true);
Config::define('SCRIPT_DEBUG', true);

ini_set('display_errors', '1');

// Enable plugin and theme updates and installation from the admin
Config::define('DISALLOW_FILE_MODS', false);

And now that you mention it I checked and it looks like DISALLOW_FILE_MODS is not allowing me to add plugins or themes from the admin. I’ve once again deactivated all plugins network wide and all themes except Twenty Eleven. I still can’t edit any tags but I can add them.

This is so strange. I don’t want to have to do this but I feel like the only way to try and get around this is to spool up a new instance, bring all the work back over and go from there.