Zsh: no such file or directory: ./bin/deploy.sh

Hi after provisioning my server I tried running
./bin/deploy.sh production test2050.website

Then I get this error zsh: no such file or directory: ./bin/deploy.sh

Can some help out please

The bin scripts were recently removed: https://github.com/roots/trellis/pull/1352 in favour of trellis-cli

The docs now show two ways to deploy:

  1. trellis-cli
  2. manually (via ansible directly)

See Trellis: Deployments | Roots Documentation

1 Like

Thank you,

I ran this and i got this error

ansible-playbook deploy.yml -e “test2050.website env=staging”

TASK [Ensure site is valid] *********************************************************************
System info:
Ansible 2.11.8; Darwin
Trellis version (per changelog): “Create mysql my.cnf credentials file earlier”

Site `` is not valid. Available sites to deploy: test2050.website
fatal: [ → localhost]: FAILED! => {“changed”: false}

PLAY RECAP ************************************************************************************** : ok=2 changed=0 unreachable=0 failed=1 skipped=6 rescued=0 ignored=0
localhost : ok=0 changed=0 unreachable=0 failed=0 skipped=1 rescued=0 ignored=0

Please can you give a solution to this. Thank you

This is not the correct command. You’re missing the site= part from the docs.

ansible-playbook deploy.yml -e “site=test2050.website env=staging”

edit: and I do recommend using trellis-cli since it makes this easier (autocompletion, simpler commands, better errors + validation)

1 Like