Brain imploding trying to get bedrock + bedrock-ansible running... please help

So — after building 2 projects with Sage (loving it), I’m finding that deploying sage using my old workflow (ie. just cramming all compiled code/image assets into git and using beanstalkapp to fart them out to staging/production servers) doesn’t work (/dist/ being .gitignored…) — and consequently I’ve started trying to play around with bedrock (hoping that it’ll help with deployment), and bedrock-ansible (in-lieu of my previous puphpet/vagrant setup).

But — try as I might — I just can’t get it working properly, and I feel like I’m just bleeding time trying to figure out how the hell to start working with a bedrock-ansible + bedrock setup.

I’m on OS X, btw.

What I’ve done so far:

  • create project root ~/sample/
  • git clone bedrock-ansible into ~/sample/bedrock-ansible
  • git clone bedrock into ~/sample/
  • configure group_vars/development with my wp configuration preferences
  • vagrant up

…aaaaand… immediately, problems.

  1. Getting a php error: Notice: Constant MULTISITE already defined in /srv/www/ on line 10. This can be resolved by killing the multisite declaration in wp-config, but then I can’t test how that’s affecting the status of the multisite activation, due to issue #2

  2. The wp site admin login user/pass I’ve configured in group_vars/development doesn’t work, at all. No matter what I try, I can’t log into WP.

  3. wp-cli doesn’t work at all, either from ~/sample/ OR from within the vagrant box, run from /srv/www/ — with different errors… running from inside the vm gives me PHP Warning: Unterminated comment starting line 16 in phar:///usr/bin/wp/php/wp-cli.php(23) : eval()'d code on line 16, and running from the host gives me a DB connection error. Bottom line: with wp-cli crippled, there’s no way to add another user with a password that I can actually log into WP with.

  4. My last hail-mary to get a user set up in the DB was to try connecting to the vagrant-ansible vm , but I can’t for the life of me figure out how the heck to get sequel pro to connect to the vm db.

So… what the heck am I doing wrong?! I’m going nuts here.

Sincere thanks in advance for help on any/all of these issues.

1 Like

Connecting to your local VM DB via Sequel Pro

  • enter username and password from group_vars/development
  • if you changed IP from Vagrantfile you’ll need to change it here


I heard a cool guy mention the multisite wiki once, in case your intention is multisite.

1 Like

Well, I’ll be… 5+ hours of googling and tearing out hair didn’t turn that up… I’ll take a look-see.

Wonder if not having the wp-config multisite rules in place in wp-config would have anything do do with the user login not getting properly configured?

I’d assumed that setting multisite: true in the group_vars/deployment config would’ve handled that setup.

Actually: just finished running another bedrock + bedrock-ansible test from scratch in a new root using the default configuration (for, non-multisite), and while that one predictably doesn’t have the multisite error, it also doesn’t provision the admin/admin user/login correctly, and I can’t log in.

Any thoughts on why ansible’s not properly setting up the user account on the initial vagrant up?


Managed to connect via sequel pro using your instructions (massive thanks for that!), and even after setting a new password using:

  UPDATE (wp_users) SET user_pass = MD5('pork') WHERE ID = (1);

…I still can’t log in. This is baffling.

I just keep getting presented with a fresh login screen at…

The reauth=1 arg in that URL is making me think that somehow the ansible/bedrock wp install isn’t setting the proper login cookie(s)?

Strange. This area isn’t my expertise (as if anything were my epertise!). But I haven’t heard of that login problem happening with bedrock-ansible.

  • Does your install of wp-cli seem to be in working order and up-to-date?
  • There weren’t any errors in the log after vagrant up?
  • wp-cli is working to the best of my knowledge — was installed fresh for another project circa yesterday, and seems fine. also, presumably, when being run from inside the vm, I’d assume that wp-cli is using a copy installed on the vm itself, not my local copy. It’s perplexing.

  • I’m going to guess that wp-cli commands run from the host are failing due to some kind of pathing error, but I can’t find any clarity on how to resolve that — particularly since with bedrock I’m still pretty unclear where wp-cli would even find the db information to connect properly, since that’s been abstracted out of wp-config

  • where would I find the log in question? I watched the vagrant up run each time and didn’t witness any explosions, but the log might show something different?


wp-cli: You’re totally right. Bedrock-ansible installs its own copy. Sorry about that.

log: I just meant the terminal output, sorry. You’d have noticed errors in red. I shouldn’t have mentioned it.

I think I’ll be better troubleshooting after some rest. Sorry.

I’m now officially certain that the password IS being setup correctly —but then getting booted out immediately after login, and sent back to the login screen.

Just tested with an incorrect password, and I get a password error. Tested with the pass configured in group_vars/development, on the other hand, and finally realized that it fails back to the login screen silently — no login error.

What the actual…

No worries, and again, sincere thanks!

Not sure, but maybe the WP logs in /srv/www/ would have info.

This has happened to me when I had similar issues with Multisite. Clear your cache, including cookies, and I think you should be able to login.


I’m… getting even more perplexed.

I tried switching browsers (was using FF, so tried chrome), and I got the following:

Cookies are most certainly not disabled. Other non-bedrock wp sites work fine. This is bananas.

Is this back to a multi site install?

Yes — multisite.

Thankfully, I seem to have been able to make a bit of progress here, and did manage to get a multisite bedrock-ansible + bedrock installation running, and accepting login credentials. phew. Not really sure what did the trick, however, unless there’s some inherent issue with using verbatim — switching to a distinct url across the board, coupled with the steps articulated at the multisite wiki entry linked above plus god knows what else seemed to work in the end.

Still wrestling with the wp-cli stuff however. I’ll break the WP-CLI issue and some other questions I’ve got into separate discussions.

Thanks for all the help folks!

I am having the same issue. Is the only way you fixed this is by using multisite support?


Have you defined DOMAIN_CURRENT_SITE on your .env file and on your group_vars/development?

Also, on your config/application.php you should have something like this somewhere in the code.

     * Wordpress Multisite
    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true); // Set to false if using subdirectories
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);


Just my two cents because I stumbled on this post having quite a similar issue yesterday.
When trying to access, I was redirected to /wp/wp-login.php and after logging in, I was presented with the login page with the same URL as you with no message :

What I finally did was trying to access /wp/wp-admin instead of /wp-admin, which worked.
I hope you’re in the same case :slight_smile: !

For more informations (if this happens to be the same issue), I don’t think I encountered the issue installing bedrock-ansible on my mac but did on windows.

Hi jchapron, first of all, your question doesn’t really have anything to do with this thread. If you have a question, you can post your own topic.

Secondly, yes, since WordPress is installed to wp in a default Bedrock installation, going to /wp/wp-admin is the correct way to do it.