Deploy Error with

Weird, new error this morning on a site that was deploying fine until just now. Error occurs almost immediately:

TASK [setup] *******************************************************************
System info:
  Ansible; Darwin
  Trellis at "Add myhostname to nsswitch.conf to ensure resolvable hostname"
[u"{{ lookup('pipe', 'curl -4 -s') }}"]:
lookup_plugin.pipe(curl -4 -s returned 35
fatal: []: FAILED! => {"failed": true}

I tried entering that line into the command line by itself and got an SSL error and the recommendation to add a --insecure flag to the command. After doing that I get:

curl '' --insecure
curl: (35) Unknown SSL protocol error in connection to

Any ideas? Seems this service is either down, or just blocked from my connection?

1 Like

The provider’s SSL certificate for that subdomain expired :astonished:

Could revert back

Allow me to use my brain for a moment…

curl --insecure (remove the S from https)


But uh yeah it’s insecure.

No need to use your brain, just use the link ^^ and grab the old URI

1 Like

Glad I saw this post!

I’m trying to setup trellis/bedrock/sage for the first time and am running into the same issue when I run vagrant up.

AnsibleError: {{ ip_whitelist | join(' ') }}: [u"{{
lookup('pipe', 'curl -4 -s') }}"]:
lookup_plugin.pipe(curl -4 -s returned 60
failed: [default] (item=jail.local) => {"failed": true, "item": "jail.local"}

@cfx - your original post fixed the issue, thanks for the help!

1 Like