Roots Discourse

ERROR! the role 'ntp' was not found

I’ve installed all of the Trellis dependencies and went through the docs to set up a local server. I setup a folder called Roots, and added Trellis and Bedrock into it. When I run vagrant up I get

`default: Running ansible-playbook...
ERROR! the role 'ntp' was not found in /Users/**/Roots/trellis/roles:/Users/**/Roots/trellis:/Users/**/Roots/trellis/vendor/roles

The error appears to have been in '/Users/**/Roots/trellis/dev.yml': line 11, column 7, but may be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

- { role: ferm, tags: [ferm] }
- { role: ntp }
  ^ here

Ansible failed to complete successfully. Any error output should be visible above. Please fix these errors and try again.`

See #4: https://github.com/roots/trellis#installation

Did you get any errors when attempting to install the roles from Ansible Galaxy (ansible-galaxy install -r requirements.yml)?

1 Like

Ben,
I did those steps and I didn’t get any errors when installing the roles from Ansible Galaxy

Doesn’t make sense that you didn’t get any errors yet the role is not there. Show us the output from ansible-galaxy install -r requirements.yml

You could also look in your vendor/roles directory to verify that the ntp role is there. I’d probably just delete those vendor/roles then rerun the command to get a fresh install:

ansible-galaxy install -r requirements.yml

Figured out the issue, my projects folder where I keep all the current projects was labeled like :: PROJECTS ::

As soon as I tried in another folder outside of this, it worked. I guess the :: in the folder name is messing something up.

The referenced README step was removed: https://github.com/roots/trellis/commit/02a8774499469486f38f300f4e3fa1afa6675a94#diff-04c6e90faac2675aa89e2176d2eec7d8.

The command to run is:

ansible-galaxy install -r galaxy.yml