Mailhog fails to start -- Daemonize not found

Hey there, [on windows]

Still on the newb train, i was going to try mailhog when vagrant didnt want to talk to me on - no connection.

i made sure all the settings are on on wherever i could find, and provisioned again
got this

==> default: TASK [geerlingguy.daemonize : Build daemonize.] ********************************
==> default: skipping: [] => (item=./configure --prefix=/usr)
==> default: skipping: [] => (item=make)
==> default: skipping: [] => (item=make install)

not sure why its skipping but hey maybe that’s ok.

ssh’d in
service mailhog status > not running
service mailhog start >

Starting mailhog.
/etc/init.d/mailhog: 28: /etc/init.d/mailhog: /usr/local/sbin/daemonize: not found

I check the repo and saw some commits, even though they seemed irrelevant to my problem, but it couldn’t hurt to go default right?
mv trellis trellis.old [because im not goo git like that]
git clone [because i am trying]
vagrant destroy
vagrant up


at least this time daemonize got built, but that didnt seem to make a difference.
i cant find anyone who’s had any problems similar to mine…

Having the exact problem with same results as above however i’m on a Mac. Issue persists whether SSL is on or off and with a fresh new trellis/bedrock project with default config. Worked fine on same project with an older version of trellis (0.9.2).


Confirmed that this is an issue. To get it up and running again I had to:

$ vagrant ssh
$ cd /opt/mailhog
$ ./mailhog

Debugging right now and will hopefully have a proper fix soon.

awesome, thanks @ben

Looks like the MailHog role needed an update! @cclass @daadir

Open up requirements.yml and bump the version to 1.0.5. I’ll be making this update in Trellis master shortly.

After you make that change, rm -rf vendor/roles/ and run ansible-galaxy install -r requirements.yml again before re-provisioning your box.


Relevant PR:

problem solved. thanks again @ben