Sage 10.0.0-beta.2 released

Sage 10.0.0-beta.2 has been released!

The most notable change from 10.0.0-beta.1 is that we’ve replaced Laravel Mix with Bud. Bud is a new project under the Roots organization that is a build tool.

Want to learn more about Bud? Take a look at the Bud vs Mix vs Encore breakdown by @kellymears and the Bud docs!

Sage 10.0.0-beta.2 also ships with Tailwind CSS v3, which is supported with Bud. You’ll see very fast build times, especially with Tailwind JIT.

Besides the changes you can reference from the release or the CHANGELOG, Sage 10 docs and Acorn docs are now available.

Next up is Sage 10.0.0-beta.3, which should be the last beta before we do a final release!

:pray: a very big thank you to everyone who has contributed to Sage 10, including:
@Log1x @QWp6t @kellymears @alwaysblank @knowler @joshf @strarsis @MWDelaney, our GitHub sponsors, our Patreon supporters, and everyone who has been creating new projects, asking questions, and reporting bugs

21 Likes

Hi @ben ,

Loving the Bud integration!

Just one think question, ACF Composer doesn’t seem to work for me anymore, is there anything i need to set up additionally?

1 Like

Not sure what error you’re seeing, but you could open a bug report over at Issues · Log1x/acf-composer · GitHub

It might be this if it’s something recent? ACF 5.11 (and 5.11.1) introduces breaking changes · Issue #98 · Log1x/acf-composer · GitHub

Brilliant, thanks for the swift response, not sure what it is, it’s just none of the admin screens are showing for Options / Gutenberg blocks for instance but the ACF Pro plugin is installed and the theme is activated.

Hey @baillieogrady! Were you able to figure out what your issue was? I’m also not seeing any of the fields on the admin. I’m using acf-composer 2.0.3 and Sage 10.0.0-beta.2.

Is the plugin activated?

Not just yet, I’m beginning to go crazy haha. I’m certain it’ll be something silly I’ve missed, I’m using docker for local dev and the wp-cli commands keep throwing a database connection error to, however I’m creating the Options folder etc… manually like I’ve always done and still no admin screens.

My setup:

ACF-composer 2.0.0
Acorn v2.0.0-beta.6
Sage 10.0.0-beta.2.

Yes, plugin and theme connected

I’ve got a feeling it’s got to do with internal updates to Acorn and how it registers Providers. I’m not really well-versed in the internals tho to dig deeper into it.

1 Like

Possibly and likewise, for now I’ve had to revert back to GUI implementation with acf-json files, hopefully we’ll find a solution soon.

npm run dev

> dev
> bud dev

    Error: TypeError: Cannot read property 'setOptions' of undefined
npm run build

> build
> bud build

...

[project] › ✔  write profile ./.budfiles/bud/profile.json
[xy] › ℹ  using config from parent compiler
    ValidationError: Invalid configuration object. Webpack has been initialized using a configuration object that does not match the API 
    schema.
     - configuration[0].resolve.modules[9] should be a object { alias?, aliasFields?, byDependency?, cache?, cachePredicate?, 
    cacheWithContext?, conditionNames?, descriptionFiles?, enforceExtension?, exportsFields?, extensions?, fallback?, fileSystem?, 
    fullySpecified?, importsFields?, mainFields?, mainFiles?, modules?, plugins?, preferAbsolute?, preferRelative?, resolver?, restrictions?, 
    roots?, symlinks?, unsafeCache?, useSyncFileSystemCalls? }.
       -> Folder name or directory path where to find modules.

virgin cloning.

Can you try with yarn on Node v16?

yes, it works that way.

node: 16.6.0
npm: 7.20.3

another problem.

added to bud.config.js:

.serve({
      port: 4200
    })
yarn run dev  
yarn run v1.22.17
$ bud dev
    TypeError: Invalid URL
    Code: ERR_INVALID_URL
error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.

edit: has tailwindcss become a base now?
how can i disappear from the project?

Looks like a fix is in the works over on the Acorn repo :crossed_fingers:t4:

In the meantime, I found that reverting Sage to 10.0.0-beta.1 (just downloaded the zip on the repo) was enough to get acf-composer back up and running. Good luck!

Please create new topics or a bug report on the appropriate repositories instead of using this announcement for support

Remove any references of Tailwind from package.json and the stylesheets.

If something like this comes up again (where there’s a fix in the main branch but not yet a release), I’d highly recommend using composer to install Acorn/whatever dependency at the specific commit you need. Definitely don’t go back to beta.1 in this case!

I’ve tagged a new Acorn release that has the fix: Release v2.0.0-beta.6 · roots/acorn · GitHub

1 Like

I’ve tried this but some css from Tailwind was still used in the final css compiled with bud in the last release. Why? Has this been fixed in beta 2?

I’m not sure when you tried this, but Beta 2 is the first release with Bud and I’m unable to reproduce:

  1. yarn remove tailwindcss --dev
  2. Remove Tailwind import’s in app.css
  3. yarn build
  4. View public/app.<hash>.css, notice no Tailwind styles are included

I have one issue. After changes in css, the page isn’t live updating the changes so I have to manually reload. It is doing it when changing blade files though.

I’m on a clean install.

EDIT: must add this line to watch in bud.config.js 'resources/styles/**/*.css',