Roots Discourse

Sage 9, illuminate/support not compatible with PHP 8

Hi, last week my brew updated PHP to v8 and suddenly sage9 composer is no more installable:

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - illuminate/support[v5.6.0, ..., v5.6.39] require php ^7.1.3 -> your php version (8.0.0) does not satisfy that requirement.
    - Root composer.json requires illuminate/support 5.6.* -> satisfiable by illuminate/support[v5.6.0, ..., v5.6.39].

I haven’t tried to upgrade illuminate/support, is it safe or the laravel subsystem is too old to be served by a modern PHP?

I’ve got the same problem this morning

Sage 9 is not stated to be compatible w/ PHP 8, and I strongly doubt that it ever officially will be–our energy is largely on Sage 10 now, although we’re always happy to review PRs.

PHP 8 is also very new, and compatibility with WordPress itself is currently not something I would feel great about. I’d strongly suggest rolling back your local version to 7.4 (or similar)–or if that’s not an option, setting up a virtualized development environment that can use 7.4.

I already reverted to PHP 7.4 and I got your point about Sage 9 not being developed anymore.
I have only one consideration (which I leave open, I have no answers :wink: ): Sage 10 is not production-ready yet and there are no release dates, and companies like mine which extensively use Sage have to stick with 9. I don’t expect hosting solutions to set PHP 8 as default anytime soon but eventually this will happen, cutting out all our lovely-crafted websites.
So, with a bit of far-sightedness, I’m asking myself:

  1. will the upgrade to Sage 10 be painless, or we’ll have to rewrite almost all our codebase?
  2. is it really impossible to upgrade illuminate/support to make it PHP8-compatible?

As a webagency I’m greatly concerned about developing now a product that will be obsolete and no more supported in a couple of years.

I want to make clear that I’m just thinking out loud here, Sage is a great product and I’ll never thank you enough for developing it :slight_smile:

4 Likes

Hi @ciromattia I agree with that the upgrade Sage will be painless and difficult, but I think in many cases php 7.4 is not implemented and many developers still working on older versions. So Sage 9 for now and for next years should works fine. Without any issue.
The problem can be if the project require php8 but as @alwaysblank said this version is very new, so a lot of packages, plugins etc are not tested with it and probably little percent of wordpress projects will want to makes changes right now. I believe your products will works next years if you choose now Sage 9 and in my opinion in next year we don’t see in wordpress alert “Wordpress version 6.5 require minimum php 8.0” :slight_smile: Will be fine

@ciromattia Does your web agency provide service maintenance on custom built sites over sage theme? Would be interested in learning more.

I work for a web agency and I’ve used Sage 10 for most projects over the last year. If you want to use it in production, you can. Finalizing the release is more about making it feature complete than solving stability issues that could keep it out of production.

Sage isn’t meant to be upgraded. It’s a starting point from which you build something unique. New versions are about bringing together new features and ideas, and aren’t built with the intent that you’ll “upgrade” from the previous version. The agency I work for has been using Sage since at least 8, and we have never encountered a need to rewrite an entire codebase.

I doubt it’s impossible. Have you tried upgrading it to see what happens? We’re always happy to review pull requests.

This topic was automatically closed after 42 days. New replies are no longer allowed.