Sage 9 page-template not working on wordpress 6.4

Show only white screen

1 Like

Did you find a solution? Experiencing the same here with Sage 9.0.0-beta.2 and WP 6.4.2 specifically.

FYI, from

1 Like

I was able to address this by adding the following to resources/functions.php:

add_filter('stylesheet_directory', function ($tdir, $temp, $root) use ($sage_views) {
    if (!str_contains($tdir, 'views')) {
        $tdir .= '/views';
   return $tdir;
}, 10, 3);

and modifying app/setup.php near line 136 like:

        // 'assets.manifest' => "{$paths['dir.stylesheet']}/../dist/assets.json",
        // Bug fix for WP 6.4.2. See
        'assets.manifest' => "{$paths['dir.stylesheet']}/../../dist/assets.json",

the above fixed it for our old sage 8 theme


oddly this broke again in the last couple of days on our production site without us making any changes since the add_filter fix above last week

I can only guess that WPEngine maybe have tried to do a backend fix for customers to avoid this and it’s broken something else, because our theme now reverted to the default theme instead with the error “Stylesheet is missing”

my solution was to copy style.css into templates/style.css … just odd that it was fine until the last couple of days

I see the WP dev team are addressing this too as there are various issues around themes that change the main template directory

but anyway leaving this here in case it helps anybody.


see also

You might try deactivating and re-activating your theme. I’ve had some weird cases where old versions of Sage thought their root was wp-content/themes/sage/templates after a WordPress update.

1 Like