Sage 9 Theme setup gives a blank page or slow localhost with vagrant

I’ve been trying to set up a sage 9 theme with little success so far. I’ve tried using vagrant and managed to get the theme visble and working but for page reloads on the localhost to take around 10-12 seconds no matter if i use standard wordpress theme or sage.

I’ve tried setting up the theme using Mamp and for the life of me I just cannot get it working when i select and activate the sage 9 theme in the wordpress backend and hit the site I am hit with a blank page. I managed to find this error when I tried using bedrock I get the below instead of the blank page.

Warning: file_put_contents(/Applications/MAMP/htdocs/Jake/web/app/uploads/cache/compiled/2c743c3a4ecb9cddce974ccebfee4e7af0701744.php): failed to open stream: No such file or directory in /Applications/MAMP/htdocs/Jake/web/app/themes/jakenew/vendor/illuminate/filesystem/Filesystem.php on line 111

Warning: include(/Applications/MAMP/htdocs/Jake/web/app/uploads/cache/compiled/2c743c3a4ecb9cddce974ccebfee4e7af0701744.php): failed to open stream: No such file or directory in /Applications/MAMP/htdocs/Jake/web/app/themes/jakenew/vendor/illuminate/view/Engines/PhpEngine.php on line 42

Warning: include(): Failed opening '/Applications/MAMP/htdocs/Jake/web/app/uploads/cache/compiled/2c743c3a4ecb9cddce974ccebfee4e7af0701744.php' for inclusion (include_path='.:/Applications/MAMP/bin/php/php7.0.13/lib/php') in /Applications/MAMP/htdocs/Jake/web/app/themes/jakenew/vendor/illuminate/view/Engines/PhpEngine.php on line 42

Has anyone got sage 9 working with mamp? im using mamp 4 and had no problem with sage 8.5.

I’ve updated the public path and dev Urls as well when setting these up.

Looks like Blade cache is attempting to write/read to web/app/uploads/cache and it doesn’t have permission

Thanks Ben it seems to be working now with mamp.

Any ideas on the localhost browser sync server being really slow at change php page etc with using vagrant?

I’m confused, you said you’re using MAMP but the title says slow localhost with Vagrant…

Yes I had to switch to MAMP because the vagrant localhost was so incredible slow it was unusable. when on vagrant and not on the localhost:3000 it was speedy.

Then i had an issue with mamp showing nothing. ideally i’d like to use vagrant but it was taking about 10 seconds to reload a php page on the localhost which I cant live with. Any ideas on why this might be that slow is that common/normal? mamp is now speedy what I’d expect

1 Like

Are you running the build tools on your Vagrant box instead of your host machine?

Even with Vagrant in the picture for local dev, you should be running any sort of front-end tooling (npm/yarn/gulp/grunt etc) from your host machine.

What does this mean exactly? I am running yarn run start from the theme folder and I also ran vagrant up from the trellis folder. yarn run start produces `Webpack is watching the files…

DONE Compiled successfully in 11880ms 12:31:28

[BS] [HTML Injector] Running…
[Browsersync] Proxying: http://villageonwhitehead.test
[Browsersync] Access URLs:

   Local: http://localhost:3000

      UI: http://localhost:3001

UI External:

[Browsersync] Watching files…

DONE Compiled successfully in 4044ms `

What am I missing?

It means exactly what I mentioned:

This is a year old thread. Please search the forum for existing threads, such as this one that was active a day ago:

1 Like