Stage Switcher 2.0.0 installation failed

When I try to install wp-stage-switcher via Composer, I receive this error:

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - jeremykendall/php-domain-parser 1.3.1 requires ext-curl * -> the requested PHP extension curl is missing from your system.
    - roots/wp-stage-switcher 2.0.0 requires jwage/purl ^0.0.6 -> satisfiable by jwage/purl[v0.0.6].
    - jwage/purl v0.0.6 requires jeremykendall/php-domain-parser 1.3.1 -> satisfiable by jeremykendall/php-domain-parser[1.3.1].
    - Installation request for roots/wp-stage-switcher 2.0.0 -> satisfiable by roots/wp-stage-switcher[2.0.0].

The installation instructions makes no mention of these. Should I install them separately and if so how?

I would imagine you don’t have ext-curl enabled for the PHP cli you’re installing from.
What OS are you using?

Ubuntu 14.04.3, Composer was installed following the Bedrock docs.

Composer doesn’t change the packages/extensions that PHP uses so you’ll need to do that manually.

sudo apt-get install php-curl for PHP 7
sudo apt-get install php5-curl for PHP5

1 Like

Thanks, that solved it.