Roots Discourse

The upload media in the local (vagrant:homestead) wordpress library is not working

Hello people,

I am having problems when i want to upload pictures to the media library of my local dev wordpress project.

I tried to search and replace “wp-content/uploads“ to “app/uploads“ with cli-wp.
I also tried to change the permission of the “app/uploads“ folder from my vagrant/homestead local server with this :
chmod +rws uploads

But it does not work. How could i fix it ? why can’t i upload pictures from my local wordpress backoffice ?
If you have some ideas, please share it to me ! thx

How is it “not working”? Are you seeing any errors? If so what are they?

From the back-office of wordpress, when i want to upload an small image inside the media library, a message is appearing saying (in french :slight_smile: ) that “an error appeared, try later“.

So i thought i may be related to a folder permission.

I also tried to put the picture manually in the “upload/2021/01“ folder but it does not seem to be recognized.

Hi,
i also noticed a disconnection from the WP backoffice everytime i tried to upload an image in the media library, on my local version of wordpress.

I am still seaching where could it come from. My main idea is to change the permission of the uploads folder in my bedrock project from the vagrant/homestead server.

It’s me again !

I read that custom code in the functions.php file could be the origin of the issue. But even if i erase it, it does not work. I also tried to desactivate all the plugins, but nothing changed.

But i realised that i was able tu upload medias from the //wp/wp-admin/media-new.php url.

I don’t underdstand what is going on. T_T

This topic was automatically closed after 42 days. New replies are no longer allowed.