Roots Discourse

Unable to run sage installer commands

I got the TTY mode is not supported on Windows platform error. So tried to find out what’s going on.

Found this No option prompts for composer sage install - on windows - #3 by mmirus

I tried the command, as pointed out in the thread php vendor/bin/sage meta in the new theme folder where the sage theme is

rootsage

I tried to google “See if we are running in Cygwin by checking for cygpath program”, not much is coming up.

Any idea what’s happening?

1 Like

Found the solution here:

simply remove php from the command, ie. instead of

php vendor/bin/sage meta

use

vendor/bin/sage meta

Hi, I’m having the same problem. I run vendor/bin/sage meta but it only takes me through the first few commands, I never got as far as choosing the CSS Framework or adding Font Awesome. Admittedly, I am using tutorials to set things up so maybe the script has been updated and you don’t offer this option any more? Or, if you do, how do I get to select between the options?

EDIT: I found the answer in another thread: No option prompts for composer sage install - on windows

using windows
installing sage first time
I can run command through php but prompt closes automatically with no accepting any input
php vendor/bin/sage meta
prompt

I cant change aur set settings
can you help?

If you are using Windows you’re gonna need to use WSL:

All commands must be run from WSL (Windows Subsystem for Linux).