Vagrant reprovision stuck on task wordpress-install : Change site owner to user

Due to some performance problems I decided to redeploy trellis but the build stopped at ‘Change site owner to user’ task. Verbose/debug output wasn’t showing anything.

Thinking destroying the droplet would help fix the problem, I did just this but the problem remains.

If I try to run trellis provision development it hangs on wordpress-install : Create web root of sites

Versions:
ansible 2.9.8
vagrant 2.2.10
trellis-cli 1.6.0 (also tried with 1.2.0)
virtualbox 6.1.26
ubuntu 20

I’m kinda lost here how to find out the problem. One older thread said to wait 1 hour but I left it overnight and it was still stuck. As mentioned there’s no error and ^c interrupts it just fine.

Any advice is appreciated.

The good old disabling the nfs in Vagrant file did the trick to get me through the reprovision for now.

1 Like

Same problem here, but I am new to Trellis. How do you disable NFS?

@cim You should do it in vagrant.default.yml, but me personally, I delete it from file named Vagrantfile by removing the two occurences of , type: 'nfs' (mind the colon in the beginning).

Oh but before you try this, you should definitely try installing nfsd-kernel-server.

Thanks, removing the nfs lines worked for me (though I have no idea if this is the right approach). And yes, I already had nsfd-kernel-server installed.

I also get stuck on task wordpress-install : Change site owner to user.
I have installed nfs-kernel-server, I have changed nfs for sshfs, I have removed ‘, type=“nfs”’ entries from Vagrantfile…
But nothing seems to be working. I have also run “trellis provision development” and also I have done “vagrant ssh” and then run ansible-playbook from within the virtualbox.
Im on linux, using a non-encrypted sdd, trellis 1.14, i tried a few versions of ansible: 2.9, 2.10.7 and 2.12
I’m running out of ideas here