Roots Discourse

Vagrant Up Fails after Mojave - (nfsd service does not appear to be running)


#1

Luckily I decided to wait until updating to Mojave until some big projects had fully wrapped up.

As soon as I updated, I get this error:

The following SSH command responded with a non-zero exit status.
Vagrant assumes that this means the command failed!

mount -o vers=3,udp 192.168.50.1:/Users/masoninthesis/Sites/jackalope-io/site /vagrant-nfs-jackalope.io

Stdout from the command:

Stderr from the command:

mount.nfs: requested NFS version or transport protocol is not supported

After sorting through plenty of solutions that didn’t work out, turns out it was super easy to fix.

The Solution:

Read this comment, and a couple of the replies above it for context.

Basically it’s an iTerm2 accessibility issue. Go to System Prefs > Security & Privacy > Full Disk Access, and add iTerm2 to the list. If you use Terminal, it should prompt you to do this upon vagranting up.


#2

Had this yesterday. Can confirm fix.


#3

…but, anyone having seemingly related issues to this with WP Migrate DB Pro? I’m trying to pull at the moment and while the database goes fine, the Media Files pull finishes 0/0 items.

Or using WP CLI shows an error for every file…

Warning: rename(/tmp/wineart-100x100-5vNo1Q.tmp,/srv/www/pipercollective.com.au/current/web/app/uploads/2018/10/wineart-100x100.png): Operation not permitted in /srv/www/pipercollective.com.au/current/web/app/plugins/wp-migrate-db-pro/class/wpmdb-filesystem.php on line 599


#4

I’ll give this a try sometime today and let you know.


#5

I just tried a pull and it worked fine. It was a “compare, then download”, and the media on the DBs were identitcal, so I uploaded a new photo and tried it again.

It worked again. So I’m not having this issue. Let me know if you find out they’re related or anything.


#6

Okay thanks I’ll see if it’s something else with my setup.


#7

I can confirm this solution works as of 2018-12-26