Vagrant Up Hang on new install



Hello there,

So i am doing a fresh install to my outdated roots theme using the old grunt/gulp way of 2013.

I followed the steps to get going with VM and vagrant. I followed all the steps here: and was able to install trellis successfully.

This is what I am using:

windows 7 (with correct 2010 distro)
VirtualBox 5.2.8
Vagrant 2.0.2

I stuck with all defaults and made no changes.

On inital run of vagrant up it installed 2 plugins and then asked me to rerun vagrant up which i did.

However on running vagrant up again i don’t get anything, nada… nill…

No error messages on console at all. I am using git bash as the console with the latest version ( 2.16.32) and running as administrator.

Also installed vagrant 1.9.8 as per a few other post here in case the latest version was the issue but the i get the message the vagrant requires version 2.0.1 to satisyfy the requirements :frowning:

Cannot seem to get past the vagrant up stage at all with no errors being shown in the console window. Tried looking for any logs etc but don’t know the locations… Kind of stumped here. All was going well but now I am stuck! Any suggestions as to how I can get this working?

Thanks in advance.


The Vagrant site has some tips on debugging:

Is there a particular reason you’re using git bash instead of CMD or PowerShell? Either of those should work, and might help you avoid some problems.

Where can I find a complete tutorial for Windows? Trellis + Sage

@alwaysblank Thanks for update…

I looked else where also and found that it was an issue with powershell 2 being installed on my windows 7 machine. This helped solve it: (may help anyone else with a similar issue).

Now working and progressing.

Only reason why I am using git bash rather than CMD is that i am able to use commands i. ls etc which don’t seem to work on CMD however not tried on powershell with the updated version I now have. Will give that a go.

Been a long time since i used roots (2013) so very rusty!