Vagrant-winnfsd not working in WSL


I tried using nfs mount in WSL as explained here:

But it doesn’t work. Here are the errors:

$ vagrant plugin install vagrant-winnfsd
Installing the 'vagrant-winnfsd' plugin. This can take a few minutes...
Installed the plugin 'vagrant-winnfsd (1.4.0)'!
$ vagrant up
sh: 1: netsh: not found
sh: 1: cscript: not found
It seems that you don't have the privileges to change the firewall rules. NFS will not work without that firewall
changes. Execute the following commands via cmd as administrator:
netsh advfirewall firewall add rule name="VagrantWinNFSd-1.4.0" dir="in" action=allow protocol=any program="\home\xxx\.vagrant.d\gems\2.4.9\gems\vagrant-winnfsd-1.4.0\bin\winnfsd.exe" profile=any
netsh advfirewall firewall add rule name="VagrantWinNFSd-1.4.0" dir="out" action=allow protocol=any program="\home\xxx\.vagrant.d\gems\2.4.9\gems\vagrant-winnfsd-1.4.0\bin\winnfsd.exe" profile=any
If you are an Windows XP user run the following command instead:
netsh firewall add allowedprogram "\home\xxx\.vagrant.d\gems\2.4.9\gems\vagrant-winnfsd-1.4.0\bin\winnfsd.exe" VagrantWinNFSd-1.4.0 ENABLE

Try to execute netsh advfirewall firewall add rule command without success.

Windows 10 1909 Pro
Trellis 1.3.0

It seems winnfsd can’t access netsh and cscript commands?

Thanks for help!


Hi DreamOn,

I currently run into the same issue.
Did you manage to make some progress?
Did you go for a different mount type perhaps?

1 Like

This topic was automatically closed after 42 days. New replies are no longer allowed.