Roots Discourse

Visual editor broken?

Just installed Sage for the first time in a pretty much empty sandbox. When editing a post in visual mode, the display shifts upward by a line every time I click inside the edit window. It gets to the point where the line where the cursor is scrolls out of view.

The problem does not seem to exist in text mode.

Switching back to the default theme or a Roots theme causes the problem to go away.

Has anyone experienced this problem?

1 Like

Have you done any development on your Sage theme, specifically the SCSS / CSS files? There might be a bad rule that’s being pulled into the visual editor, since the visual editor display makes use of the custom CSS of the theme.

No. I will pass it on to my developer to check it out. Thanks.

Hi, I’m the developer… We tried to install again Sage on a clean WP install on the same server. We have the same problem. There is a JS that adds to wp-admin Visual editors IFRAME an extra height everytime you click inside the editor box. IFRAME style=“height: 1527px;” is getting bigger dinamically:

It happens with all the other plugins turned off. If we change theme we don’t have this problem.

I also installed the same Sage on a test WP on another server, there I haven’t this problem.

Is there any server setting that can conflict with Sage?

thanks

The only conflict I’ve found that causes that is that the editor-style pulls in main]1 so that the WYSIWYG looks the same as the site.

If you are doing 100% height on the html, body, etc. I’ve noticed the WYSIWYG will do that. Either add in a height: auto; after that in the editor-styles file, or give height: 100vh a chance, and you only need to use that on the container needed, not on the html or body.

1 Like

Hey, I found here the solution:

Add to editor-style.scss:

#tinymce { height: auto;}

cheers

1 Like

Not working for me :frowning: