Roots Discourse

WP CRON has been disabled on your install

Expanding on this topic I’d like to know what it means to get the following error and how to resolve it:

WP CRON has been disabled on your install which may prevent this update from completing.

Unlike the people in the referenced post, my CRON tasks aren’t running, and the only way to complete them seems to be by running them manually 1 at a time, which is extremely innefficient for 18+ tasks.

Any advice on how I can get these updates to run automatically like they used to? P.S. This particular update is a Woocommerce database update.

UPDATE: It would appear I spoke too soon in this particular case, as the updates did end up running after some time… But I ran into this exact situation the other day on a different site where they didn’t run, even after a half hour wait. Is is just that I didnt wait long enough, or is there perhaps something else going on?

P.S. From what I remember, these updates used to be instant in the past.

Bedrock disables WP Cron as per the WordPress docs unless you specifically tell it otherwise. See: https://github.com/roots/bedrock/blob/571f5538c687f50fb06cd81a7c21e0be4d8f5f17/config/application.php#L91

Also take a look at the WordPress docs: https://developer.wordpress.org/plugins/cron/hooking-wp-cron-into-the-system-task-scheduler/

All that “disable WP Cron” does is stop running the cron task checker on every page load. It assumes you will then be hitting wp-cron.php in another way, i.e. with a system-level cron task. I don’t know where your site is hosted, but it may be that your host automatically hits that file on some schedule. If you’re on Kinsta, for instance, they’ll hit wp-cron.php every 15 minutes: https://kinsta.com/knowledgebase/disable-wp-cron/

1 Like

Ah okay so it’s likely just a timing thing I imagine? The sites in question are both hosted on DigitalOcean for the time being, provisioned and deployed with Trellis.

This topic was automatically closed after 42 days. New replies are no longer allowed.