Roots Discourse

Yarn:build problem - copy-globs-webpack-plugin throwing error ... HELP?!

Hey everyone,

I’ve encountered an issue that I cant for the life of me get around and im completely stumped. Have tried rebuilding my environment and screwing with dependencies in every way imaginable and still no luck. Wondering if anyone knows a solution to this issue?

I’ve read this thread:

https://discourse.roots.io/t/resources-assets-images-typeerror-compilation-filedependencies-has-is-not-a-function-copy-globs-webpack-plugin-yarn-not-working/14994/5

which suggests downgrading to copy-globs-webpack-plugin@0.2.0. So I’ve done that but the issue persists. I’ve also read that switching to copy-webpack-plugin works, however this isnt an option for me.

Any chance that anyone out there might have some insight? I’m desperate at this point. I’m doing this on Windows, not sure if that’s why the issue is cropping up.

This error appears to be from v0.2.0. What’s the error you get when installing v0.3.0?

1 Like

Hadn’t you updated your sage webpack version to 4 by any chance?

Consider yourselves my heroes. alwaysblank, that was very helpful. Dont know why I thought it was backward.

I think also running “Yarn --force” helped me too, seems like when i was running yarn previously it was installing things globally by default. When I ran it with --force it seemed to copy all the global packages to my project folder and install some missing packages.

In any case, thanks so much. A solution 3 days in the making. Bards will sing songs of your heroism for generations.

:beers::beers:

now i can actually get down to business.